CentOS 7系统hold包不允许升级

出于某些原因,我们可能需要将某些包锁定,以防止在更新系统的时候,某些包也跟着自动更新了,比如说我们自行编译的Nginx,由于添加了某些特有模块,如果在更新系统的时候自动更新了源里的版本,可能会导致出问题,所以,我们可能需要把对应的包给固定住。

CentOS系统默认不带锁定包功能,我们需要安装一个yum插件,命令如下:

yum install yum-plugin-versionlock

安装好之后,我们就可以直接hold我们需要锁定的包了,比如说我们刚才说的NGINX:

yum versionlock nginx

当然,你也可以直接编辑下面这个文件:

/etc/yum/pluginconf.d/versionlock.list

作用也是一样的。

查看被锁定的包:

yum versionlock list

清空被锁定列表:

yum versionlock clear

锁定软件包之后,我们再次更新系统的时候就不会更新被锁定了的包了。

“CentOS 7系统hold包不允许升级”的一个回复

发表评论

邮箱地址不会被公开。 必填项已用*标注