CentOS/Debian/Ubuntu/macOS手动安装Composer

Composer是PHP的包管理工具,类似于Debian/Ubuntu的apt,CentOS的yum,现代PHP程序,多少都会用到这个,通过这货,我们能很方便的安装各个我们所需要的包,还可以用来安装一些PHP框架本身,比如说Laravel、Lumen,这里记录一下Composer的手动安装方法。

先记录一下各个发行版用包管理器安装Composer的命令。

Debian/Ubuntu包管理器安装Composer

apt install composer

CentOS包管理器安装Composer

yum install epel-release -y
yum install composer

macOS安装Composer

brew install composer

虽然各个发行版都自带了这个软件包,但是如果直接用包管理器安装的话,因为系统包管理器要解决依赖问题,所以,可能会安装一些我们并用不到的包,比如说CentOS7自带的PHP是5.4,如果直接用yum安装Composer的话,可能会把PHP5.4给顺带安装上,而如果我们的运行环境不是5.4的话,这就会产生冲突,所以,我们为了不安装别的软件包,可以选择手动安装的方式安装Composer。

因为Composer依赖PHP环境,所以手动安装Composer之前可能需要配置好PHP环境,由于各个发行版已经自带了PHP包,直接安装就行,如果是CentOS,想安装不同版本的PHP,可以参考这篇文章:CentOS6/7使用Webtatic yum包管理安装PHP5.5/5.6/7.0/7.1/7.2

安装好PHP环境之后,我们就可以手动安装Composer了。

手动安装Composer

官方的方法是使用composer-install,可能是出于安全考虑,使用一个安装脚本安装,且校验了安装脚本的SHA384,这是Composer的官方安装步骤:

php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
php -r "if (hash_file('SHA384', 'composer-setup.php') === '544e09ee996cdf60ece3804abc52599c22b1f40f4323403c44d44fdfdd586475ca9813a858088ffbc1f233e9b180f061') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r "unlink('composer-setup.php');"

但是,如果我们不想这么麻烦,我们其实可以直接安装Composer本身,步骤也很简单:

wget https://getcomposer.org/composer.phar
chmod +x composer.phar
mv composer.phar /usr/local/bin/composer

这样就算完成Composer了,怎样,简单粗暴吧?

Composer使用

安装完之后,我们来试一下Composer:

composer -V

如果正常的话,应该能看到Composer输出的版本信息。

如下命令可以查看Composer的帮助信息:

composer --help

update:顺便记录一下Windows及macOS下的安装过程。

Windows下安装Composer

之前Composer是为Windows提供了安装包的,现在貌似也取消了,统一用上面哪个安装脚本安装了,所以,在配置好PHP之后,只要打开cmd终端,直接使用上面那4行命令用安装脚本安装就好了。

“CentOS/Debian/Ubuntu/macOS手动安装Composer”的一个回复

发表评论

邮箱地址不会被公开。 必填项已用*标注